radykal | Support Center Chooser

For which product do you need support?

Fancy Product Designer Multistep Product Configurator Another

Start a new topic

Add to Cart button not working after design

I am currently running Wordpress (4.5.2), Storefront Theme, Woocommerce (2.5.5) plug in and Fancy Product Designer (3.1.0).  I have built a Woocommerce product page with the Fancy Product Designer running on the front end.  The Front End of the Fancy Product Designer works as it should, but when I hit the "Add to Cart" button, the page reloads and does not add the product to the cart.  If I create a product without the Fancy Product Designer on the page, the "Add to Cart" works fine.  I have tried disabling all of my plug ins and this still did not change the functionality.  I have tried 3 different themes hoping it was the theme that I was using.  This did not work either.  I have re-installed my theme, Woocommerce and Fancy Product Designer and still nothing.  I used Chrome to inspect the "Add to Cart" elements on the Fancy Product Designer page and the standard product page.  Here is what I found:


Standard Add to Cart Button

<a rel="nofollow" href="/shop/?add-to-cart=86" data-quantity="1" data-product_id="86" data-product_sku="2" class="button product_type_simple add_to_cart_button ajax_add_to_cart">Add to cart</a>

 

Fancy Designer Add to Cart Button

<button type="submit" class="single_add_to_cart_button button alt">Add to cart</button>


So, as you can see, the standard Add to Cart is totally different than the Fancy Product Designer.   I am just scratching the surface with PHP and CSS, so I can see that there is an issue but do not know how to fix it.  Any help would be greatly appreciated.


Patrick


Set your option to turn on debugging and see if you get a error.. on load.

Also right click on page and select inspect and see if you have any errors showing.. This could be as simple as installing a minimize plug in for js 

If you have any errors showing you will see a red circle with a x then click console and see what is causing the errors.


Let us know.. 

Jason

Jason,


Thanks for the reply.  In Debug, There are no errors showing up.  When I inspect, there are 3 errors



I am not sure where to go from here.

Patrick


Hi Patrick Ruggeri,

Have you found any solution?

Yeah, we are having the same exact issue on our end.

same here , i already update to FPD 3.4.2 , but still same problem

Most likely a server issue - check your browsers developer console or open a support ticket.