radykal | Support Center Chooser

For which product do you need support?

Fancy Product Designer Multistep Product Configurator Another

Start a new topic
Answered

Designs options not being correctly implemented

Hi, I am trying to set options for the Designs as you can see in the attached screenshot.


The problem is that on the frontend the Designs are still Movable and Resizeable when they should only be Deletable and have the Advanced Editing enabled.


The only thing that works is if I set all the option to NO then no options appear on the Frontend and the Design stays in its place.


I have disabled all caching and cloudflare as well but the settings are not taking effect as they should... Can you please help?


Best Answer

Did you also check the designs settings on WooCommerce Designs itself?


I've still been attempting to track this down and I think I've run into at least one issue that I'm having. It appears that not all option vales are getting serialized and submitted properly on the manage designs screen.

In one instance I'm missing the option for advancedEditing being set properly. In another, I'm missing bounding_box_control=no.

It appears that that there may be an issue with the modal itself in that certain fields aren't getting a default value if they are not set in the database, and therefore are not saving. It is my belief that when you first select to enable the settings for individual designs, options with yes / no values are not getting defaults, and subsequent visits to edit the same design therefore do not load values into the fields. This results in the form serializing improperly and not saving values until a user toggles each option.

Can confirm that this is still a bug.

I've been working on getting this resolved for hours and I'm continuing to investigate. 

@Genr8r is right on how I would expect the cascading of settings to be applied and I'm specifically inspecting the code to see if this cascade is where the breakdown in.

In the case of @asad having and problem and @Johnny not being able to replicate it, I think it could have also been an issue with changing individual product settings in the woocommerce product

image



Additionally, My issue relates to global default properties being different between my designs and custom images. I've proposed separating these settings into different categories as is detailed in this Feature Request

I had introduced a problem with CSS in the UI Composer. I pulled that which partly resolved my issue. I had been hiding an element (display:hidden) that I didn't want to be part of product customization but my selector was too broad. It is not clear to me how this would impact the cascade of parameters that I described earlier...

design settings should override category settings which should override default settings. I have not had a chance to look at this since my ticket reply from Johnny (which was rather timely!).


I will test a little further and then post the results back here in the event that they are helpful.

This problem hasn't been resolved for us yet too. Unfortunately, Johnny could not recreate the problem and felt that the problem was isolated to us... Would be great if someone can share a fix.

I am having a similar problem. I would expect the individual design settings to take precedence over category settings which should take precedence over general settings. However, the only settings that seem to work are general settings and I have one category that should allow resizing and another that needs to keep the designs at their original size. Should I also open a ticket?

yes, please. 

Still having this problem... basically the options here admin.php?page=fpd_settings&tab=element_properties#images conflict with the Category Wide options here admin.php?page=fpd_manage_designs 


So the result is inconsistent. Some time some options take effect and sometimes they don't. Like I want people to be able to rotate the pictures they upload but not the designs that I put in the design module but because of this issue whatever I try in some categories the design will be rotatable and in some they won't be regardless of the options selected for that design category or that design individually. 


Even tried every design element separately and on a fresh install with no other plugins and themes but still, have the same inconsistent result.


Should I open a ticket?

okay. Glad you figured it out though. If you still have problems please open a support ticket so we can have a closer look at it. 

The single design images have the individual options disabled as you can see here https://1drv.ms/u/s!AhdPbL-zV9pclT3dY8sLa4_b3nwA 

Maybe you can also check whether you've set settings for your designs in

Fancy Product Designer -> Designs -> Choose a design -> Click on "Options" of each design image. These settings are the most important ones. 

I have also checked on a test server and on certain design categories the category options take affect while on others they take partial affect and on some it doesn't take affect at all.

I think I have found the issue of the conflict as explained in this screenshot https://1drv.ms/u/s!AhdPbL-zV9pclTviW_E-S9gMvSHI 

Please see the following screenshot... The problem is still there even after I have correctly set the options and saved


https://1drv.ms/u/s!AhdPbL-zV9pclTl4t2KPovCYERsx 


Could it be because of a conflict with these settings?


https://1drv.ms/u/s!AhdPbL-zV9pclToZtiI1trGChBDT 

go to Fancy Product Designer -> Designs -> Choose a design -> Edit category options

Could you perhaps clarify what you mean by "designs settings on WooCommerce Designs" I can double check?

Login or Signup to post a comment