radykal | Support Center Chooser

For which product do you need support?

Fancy Product Designer Multistep Product Configurator Another

Start a new topic
Answered

bug in "individual product settings" - UI Layout change dropdown not working - solved

 Hi all,


even though we created two or more different User Interface Layouts in the composer,
we could not select any one of these in the "individual product settings"

The dropdown arrow was clickable, and the arrow changed from pointing down to pointing up,
but none of the names of those individual layouts appeared.


We solved this by changing the following:



fancy-product-designer/admin/modals/modal-individual-product-settings.php
line - 33
find - <select name="product_designer_ui_layout" class="radykal-select2">
replace with - <select name="product_designer_ui_layout" class="">

done!


now it works fine.

see screenshot



Best Answer
Make sure you create at least one additional UI Layout, save it under a distinguishable name and then it should work. There are no other steps

 


Thank you this helped I was able to select the UI, but even though its selected for the individual product. The UI that shows up is just the default one.

Are there any other steps you can share with me or did that completely solve the problem for you?

Answer
Make sure you create at least one additional UI Layout, save it under a distinguishable name and then it should work. There are no other steps

 

Thank you I will give it another try. In a odd way it worked as you suggested originally, BUT the options for example magnify still show up even if removed from the new UI layout. Solution was to remove it from the default one as it seemed to apply the change to all of the UI's.


Thank you

Yes I had the same problem. To remove module/action option icons I had to remove them from the default UI also.
Until I read this post I was stumped, so thank you (I think it is a bug).

If you are on the most recent version there should be no more issue with this (currently 3.3.0) The issue existed back in 3.1.X I believe.

Login or Signup to post a comment